通信人家园

 找回密码
 注册
搜索
热搜: 家园 活动
凌华科技
恒扬科技

军衔等级:

  下士

注册时间:
2011-4-1
跳转到指定楼层
1#
发表于 2017-2-10 16:03:57 |只看该作者 |倒序浏览

1、 基本配置

1、打开多context的服务功能

[local]SE800(config)#service multiple-contexts

2、打开context之间路由功能

[local]SE800(config)#service inter-context routing

注:

为什么建议把PPPoE拨号的应用放在PPP这个context,因为local这个context是全局的管理context,为了让管理上相对清晰,也便于让每个不同的应用有不同的认证策略,所以我们建议把PPP的应用单独建立一个context,并把相关的认证策略设置在PPPcontext里面,而上连的链路利用local context的,所以需要打开context之间的路由。

总之,我们的建议是同一种应用放在一个context里面,新增应用另外设置新的context

3、设置设备的主机名字

[local]SE800(config)#system hostname SE800

4、增加context

[local]SE800(config)#context context-name

5、增加管理interface

[local]SE800(config-ctx)#intface mngt

[local]SE800(config-if)#ip address 10.0.0.1 /24

把管理interface绑定到port 7/1

[local]SE800(config)#port ethernet 7/1

[local]SE800(config-port)#bind interface mngt local

注:管理口没有路由功能,也不会被发布到local的路由域里面,通常用于软件升级。

6、打开contexttelnet功能

[local]SE800(config-ctx)#service telnet

7、增加管理者帐号

[local]SE800(config-ctx)#administrator admin password redback

可选设置

[local]SE800(config-administrator)#priviledge start 15

如果不设置priviledge级别,缺省为15

增加操作者帐号

[local]SE800(config-ctx)#administrator operator password redback

[local]SE800(config-administrator)#priviledge start 1

[local]SE800(config-administrator)#priviledge max 10*

*注:操作者的权限可以根据实际需要来设置,最低为1,最高为1515级实际上就是成为最高权限管理者。

8、配置syslog

console口上可以显示log信息

logging console

配置syslog服务器

logging syslog 209.101.114.3 facility local7

logging syslog 209.101.114.28 facility local7

9、配置SNMP

打开SNMP

[local]SE800(config)#snmp server

设置SNMP view

[local]SE800(config)#snmp view Inet_view internet included

设置community名称

[local]SE800(config)#snmp community SR/SE800

10NTP和时区设置

指定NTP服务器

ntp server 209.97.30.158 version 3  context local

设置中国时区

system clock timezone GMT+8 8 0 local

2、 上连链路配置

配置上连interface

[local]SE800(config-ctx)#interface toNE5000

[local]SE800(config-if)#description to NE5000 248.86.122.85/30

[local]SE800(config-if)#ip address 248.86.122.86/30

把上连interface绑定到相应的互连端口

[local]SE800(config)#port ethernet 1/1

[local]SE800(config-port)# description to toNE5000 port XXXX

[local]SE800(config-port)#bind interface toNE5000 local

3、 全局和调用参数设置1、 Key chain的配置

[local]SE800(config)#key chain keyname key-id 10

[local]SE800(config-key-chain)#key string key

2、 Qos Policy配置

SE800的限速需要跟radius服务器配合才能实现,通过Redback的厂家专有属性VSA(在标准属性26Vendor-Specific的取值为2352)的91号属性Sub-Profile-Name即用户描述名称可以实现限速,radius服务器在dictionary文件中增加该属性VSA。根据用户申请的带宽,对该用户记录(user文件)中对这项用户描述名称的字符串类型进行赋值。用户拨号成功后radius把该用户的属性值下发给SE800SE800得到Subscriber profile名称后,根据在BRAS上设置对应subscriber profile name的具体属性值,继而应用到subscriber上。

这个91号的描述如下:

VSA序号

属性名称

含义

属性值类型

91

Sub-Profile-Name

用户描述名称

字符串

SE800预先设置好具体的subscriber profile名称,比如针对1M下行速率的用户,设置

subscriber profile bw_1Mlimit

   qos policy bw_1Mdown metering

通过radius下发这个1M下行速率用户的91VSA专有属性值,SE800根据这个Sub-Profile-Name的名称1Mdown,对应subscriber profile 1Mdown,把profile里具体的速率设置bw_1Mdown应用到该用户,从而达到限速的目的。

通过这种方法,当针对1M下行速率的用户还需要增加某些其他专有属性时,就不需要在radiusdictionary文件中增加新的VSA了,只需要在subscriber profile里加上新的其他属性,SE800就可以把它们灵活地应用到subscriber里了。

busrt = 带宽(bps) × 0.8 / 8

qos policy bw_512kup policing

   rate 512 burst 51200

qos policy bw_512kdown metering

   rate 512 burst 51200

qos policy bw_1Mup policing

   rate 1024 burst 102400

qos policy bw_1Mdown metering

   rate 1024 burst 102400

qos policy bw_2Mup policing

   rate 2048 burst 204800

qos policy bw_2Mdown metering

   rate 2048 burst 204800

qos policy bw_3Mup policing

   rate 3072 burst 307200

qos policy bw_3Mdown metering

   rate 3072 burst 307200

qos policy bw_4Mup policing

   rate 4096 burst 409600

qos policy bw_4Mdown metering

   rate 4096 burst 409600

qos policy bw_5Mup policing

   rate 5120 burst 512000

qos policy bw_5Mdown metering

   rate 5120 burst 512000

qos policy bw_6Mup policing

   rate 6144 burst 614400

qos policy bw_6Mdown metering

   rate 6144 burst 614400

qos policy bw_7Mup policing

   rate 7168 burst 716800

qos policy bw_7Mdown metering

   rate 7168 burst 716800

qos policy bw_8Mup policing

   rate 8192 burst 819200

qos policy bw_8Mdown metering

   rate 8192 burst 819200

qos policy bw_9Mup policing

   rate 9216 burst 921600

qos policy bw_9Mdown metering

   rate 9216 burst 921600

qos policy bw_10Mup policing

   rate 10240 burst 1024000

qos policy bw_10Mdown metering

   rate 10240 burst 1024000

##下列QoS限速设置用于专线限速

qos policy bw_20Mup policing

   rate 20480 burst 2048000

qos policy bw_20Mdown metering

   rate 20480 burst 2048000

qos policy bw_30Mup policing

   rate 30720 burst 3072000

qos policy bw_30Mdown metering

   rate 30720 burst 3072000

3、 atm profile 配置

[local]SE800(config)#atm profile ubr

[local]SE800(config-atmpro)#shaping ubr

[local]SE800(config)#atm profile ubr1M

[local]SE800(config-atmpro)#shaping ubr pcr 1000

[local]SE800(config)#atm profile vbr1M

[local]SE800(config-atmpro)#shaping vbr-nrt pcr 1100 cdvt 20 scr 1000 bt 10

注意:信元速率单位为kbpsCell Delay Variation Tolerance (CDVT)为信元延迟抖动容限时间,单位为msBurst Tolerance (BT)为并发容限,即以PCR速率的允许时间,单位为ms。原则上,这些参数应该和对端ATM交换机端口的PVC参数保持一致。

通过ATM上行的wlan设置

[local]SE800(config)#atm profile wlan

[local]SE800(config-atmpro)#shaping ubr

[local]SE800(config-atmpro)# radius attribute nas-port-type 19

4、 dot1q profile配置

wlandot1q profile设置

[local]SE800(config)#dot1q profile wlan

[local]SE800(config-dot1q-profile)#radius attribute nas-port-type 19

profile设置可在用于WLAN接入的以太网端口上引用。

5、 timeout时间设置

telnet session空闲过时设置

[local]SE800(config)#timeout session idle 5

telnet会话在5分钟内没有输入时timeout退出

telnet登录响应过时设置

[local]SE800(config)#timeout login response 5

当出现login界面5分钟没有进入时timeout退出

6、 PPPoE设置

pppoe service-name accept-all

SE800允许接受任何的service-name

可选设置 pppoe tag ac-name 9A051080145520-Sanming-SMS

对于某些PPPoE客户端软件,会在服务名中记录AC-Name的值,在进行割接时,需要把原先BASAC-Name写进SE800,防止这部分用户的拨号失败。

pppoe always-send-padt

我们知道,PPPoE的协议堆栈如下:

从上图来看,当上层协议PPPsession已经结束的时候,理论上处于PPP协议和Ethernet协议之间的PPPoEsession维持就没有继续存在的意义。在SE800在有些特定情况下发生挂死,就是因为无效的PPPoE session继续保留在SE800上造成的。所以这条命令的作用就是,在PPP已经结束后,立即发送PPPoEPADT终止报文,使得PPPoEsession也随之结束。

这条命令对于体彩用户非常有必要,SE800作为体彩VPDNLAC,由于PPP是终结在LNS上,SE800没有机制来发送LCP echo请求进行ppp keepalive检测,所以当LNS终止了PPP连接后,需要用这条命令来立即结束PPPoE连接,防止体彩用户在SE800上的短暂挂死,并提高拨号成功率。

4、 上连链路和CONTEXT之间路由协议设置

1、上连链路OSPF路由设置

打开ospf路由

[local]SE800(config-ctx)#router ospf 1

设置backbone area

[local]SE800(config-ospf)#area 0

ip interface加入area

[local]SE800(config-ospf-area)#interface lp1

[local]SE800(config-ospf-area)#interface toNE5000

[local]SE800(config-ospf-if)#cost 80   //设置链路cost

[local]SE800(config-ospf-area)#interface toT640

[local]SE800(config-ospf-if)#cost 80   //设置链路cost

重发布静态路由和直连地址

[local]SE800(config-ospf)#redistribute connected metric 6 metric-type 1

[local]SE800(config-ospf)#redistribute static metric 7 metric-type 1

注:禁止在local context既设置ospf动态路由协议,又设置缺省路由,否则缺省路由会通过redistribute static这个条命令发布到area 0里面,造成城域网内缺省路由指向SE800metric-type 1为类型1 其权值不断累加,权值类型的默认值为2

2context之间静态路由设置

local contextpppoe contextIP pool静态路由设置

[local]SE800(config-ctx)#ip route 224.176.24.0/24 context pppoe permanent

local contextpppoe contextloopback地址静态路由设置

[local]SE800(config-ctx)#ip route 224.177.208.16/32 context pppoe

3pppoe context的缺省路由设置

[local]SE800(config-ctx)#ip route 0.0.0.0/0 context local

5、 IPoE配置1、 单链路上IPoE配置

参考上连链路配置

2、 多链路上IPoE配置

建立interface

[local]SE800(config-ctx)#interface ipoe multibind

[local]SE800(config-if)#descrition ipoe on multi-circuit

[local]SE800(config-if)#ip address 220.187.207.65/26

[local]SE800(config-if)#ip arp secured-arp

注:ip arp secured-arp为了防止地址冒用,multibind参数为必须。

可选的安全设置:

启用RPFreverse path forwarding)反向路径验证

Ip verify unicast resource reachable-via rx

建立用于绑定的静态subscriber

[local]SE800(config-ctx)#subscriber name ipoeuser1

[local]SE800(config-sub)#descrition ipoeuser1

[local]SE800(config-sub)# ip address 220.177.207.67

[local]SE800(config-sub)# ip address 220.177.207.68

[local]SE800(config-sub)# ip address 220.177.207.69

[local]SE800(config-sub)# ip address 220.177.207.70

[local]SE800(config-ctx)#subscriber name ipoeuser2

[local]SE800(config-sub)#descrition ipoeuser2

[local]SE800(config-sub)# ip address 220.177.207.71

把静态subscriber绑定到多条PVC

[local]SE800(config)#port ethernet 1/3

[local]SE800(config-port)#dot1q pvc 11

[local]SE800(config-dot1q-pvc)#bind subscriber ipoeuser1@local

[local]SE800(config)#port ethernet 1/3

[local]SE800(config-port)#dot1q pvc 12

[local]SE800(config-dot1q-pvc)#bind subscriber ipoeuser2@local

配置注意事项:

1、 port使用时,必须先设置no shutdown命令。

2、 如果不退到[context name]hostname#执行模式下要让配置的语句生效,需要执行commit命令提交,如果不让已经回车执行的语句生效,可以用abort命令恢复。

3、 保存设置用save config /flash/filename.cfg,保存到硬盘上用save config /md/filename.cfg

4、 调用某设置为config filename.cfg此操作为增量设置,也就是说可以调用多个文件配置,配置是增量补充进去的。

5、 系统启动时,缺省调用的配置文件名是/flash/redback.cfg,如果配置不保存为/flash/redback.cfg,需要设置boot configuration filename.cfg





使用道具 举报

军衔等级:

  大校

注册时间:
2007-12-19
2#
发表于 2017-2-10 22:09:09 |只看该作者
爱立信在国内还有这个玩意呢,没想到

使用道具 举报

军衔等级:

  中校

注册时间:
2007-1-4
3#
发表于 2017-2-11 08:25:39 |只看该作者
赞!!!!!!!!!!!!!!!

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

Archiver|手机版|C114 ( 沪ICP备12002291号 )|联系我们 |网站地图  

GMT+8, 2017-2-19 19:55 , Processed in 0.096637 second(s), 15 queries , Gzip On.

Copyright © 1999-2016 C114 All Rights Reserved

Discuz Licensed

回顶部